Jira Service Desk: Editing an Issue changes the Request Language to Unknown

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem:

Whenever a Service Desk Agent edits an issue Using the Edit button, Request Language changes to Unknown.

Cause:

Request type is present in the Issue Edit Screen which is fetching an incorrect value.

Solution:

Remove the Request Type Field from the Issue Edit Screen

NOTE: The behaviour has been Noted by the Developers and they are working for a fix for the same.

Updated on April 8, 2025

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