JIRA Obsolete custom fields are displayed when doing an issue search using JQL
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When doing a JQL search for an issue, fields with the same name are displayed although one of them is obsolete and not used (see screenshot below).

Cause
A new custom field was created to replace an existing one which has the same name. The obsolete field has its Search Template set to Free Text Searcher instead of None.


Solution
Set the Search Template of the obsolete field to None.
Do a Background re-index during a non-busy period.

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