Error AADSTS50105 encountered when logging into Atlassian cloud

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

A managed account enforced with SSO through Microsoft Entra ID may encounter the AADSTS50105 error code.

  • The managed account is logging into the Atlassian cloud.

  • The user is automatically redirected to the Microsoft login page for authentication.

  • The user can authenticate with the Microsoft UPN and password.

  • The following error is returned to the user.

1 2 3 4 5 AADSTS50105: Your administrator has configured the application Atlassian Cloud ('<APPLICATION_ID>') to block users unless they are specifically granted ('assigned') access to the application. The signed in user '<email address>' is blocked because they are not a direct member of a group with access, nor had access directly assigned by an administrator. Please contact your administrator to assign access to this application.

Cause

The Entra ID account has not been granted permission to authenticate via the Entra ID application configured for SSO with Atlassian Access.

Resolution

Please request the Entra ID administrators to perform either of the following.

Option 1: Allow anyone in Entra ID to authenticate via the Atlassian cloud application

  • Go to https://entra.microsoft.com/

  • Navigate Enterprise Application > Atlassian cloud

  • Open the Properties settings

  • Set the "Assignment required?" settings to No

  • Save

Option 2: Grant permission to the specific account facing the AADSTS50105 error.

  • Go to https://entra.microsoft.com/

  • Navigate Enterprise Application > Atlassian cloud

  • Open the Users and Groups settings.

  • Assign the account directly to the application or add the account as a member of any assigned group.

Updated on April 21, 2025

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