Selecting custom date field in Advanced Roadmaps plan configuration leads to error Make sure to add this date field to all the issue sources of this plan

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Jira users can't select a custom date field in the Start Date and End Date dropdown menus of the Scheduling configuration of an Advanced Roadmaps plan. The custom field is greyed out due to the error below:

1 Make sure to add this date field to all the issue sources of this plan

Environment

Jira Software Data Center on any version from 9.0.0.

Diagnosis

This KB article is relevant if:

  • The Custom Field is greyed out in the date dropdown menus of the Scheduling configuration.

  • The error Make sure to add this date field to all the issue sources of this plan pops up.

Cause

For a custom field to be used in a Plan's Scheduling configuration, the contexts associated to this custom field need to include:

  • All the projects used by the plan (as per the Plan's Issue Sources configuration).

  • All the issue types.

If the "Make sure to add this date field to all the issue sources of this plan" is shown, it is because the Context(s) associated to the Custom Field as not correctly configured:

  • Either the contexts are not including all the Projects used by the Plan.

  • Or the contexts are not including all the issue types for all the Projects.

Solution

Get the full list of project(s) associated to the plan

To check which projects are used by the Plan, you will need to follow the steps below:

  • Go to the Plan's Issue Sources configuration and check what type of source it is using (Project vs Board vs Filter). In the example below, the Plan is using 2 projects (SCRUM and KANBAN) in its source:

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  • If the Issue Sources configuration is using Projects, then getting the list of projects associated to this Plan is straight forward. You can move on to the next section Fix the Custom Field Context Configuration

  • If the Issue Sources configuration is using a Board or a Filter instead, then getting the list of Projects used by the Plan will be a bit trickier:

    • In case of a Board, open the Board configuration (via Board > Configure > General), and check the Projects in board section

      • This section will show the list of projects associated to the board

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      • ⚠️ Note that if the Board filter does not explicitly filter by projects, you will get the message "The projects in this board cannot be listed because of the complexity of the board filter".

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        • In such case:

          • The Plan will not be able to identify which Projects should be included in it, and it will be impossible to select any Custom Field in the Plan Scheduling configuration.

          • It will be necessary to edit the Board Filter, so that is explicitly filters issues by projects

    • In case of a filter, open the filter and check if it is explicitly filtering issues by projects (with the component "AND project in ("ABC", "DEF", etc...))

      • If it does, get the list of projects used by this filter

      • If it does not, you will need to explicitly add the component "AND project in ("ABC", "DEF", etc...)" at the end of the filter to make it search through specific projects

Fix the Custom Field Context Configuration

Once you identified which projects are used by the plan, you can go to the custom field context configuration by following the steps below:

  • Go to ⚙ > Issues > Custom Fields

  • Search for the custom field of type date

  • Navigate to Actions ... > Configure Contexts

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  • Take a look at the contexts configured for this Custom Field and check which issue type(s) and project (s) are associated to them.

    • In the example below, the Custom Field only has 1 Context associated to it, and this context only has 1 project (SCRUM) and 1 issue type (Story):

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  • Fix the Context configuration by making sure to include:

    • All the Projects identified in the section Get the full list of project(s) associated to the plan

    • All the issue types

  • In the example below, the Context was changed to include the 2 projects SCRUM and KANBAN, and all issue types:

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Configure the Plan Scheduling settings

Go back to the Plan Scheduling configuration, and verify that the custom field is now selectable without any error:

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Updated on April 24, 2025

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