Missing Done Issues in Advanced Roadmaps Plan - Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Some issues in a DONE status (status in which category is DONE) are missing an advanced roadmap plan, while they are visible from the board linked to the plan.

Example

  • The SCRUM-14 issue is in the Done status (green-colored status):

    issue detail view of a story. The status is set to [Done]. the status field is in green colour, indicating that the status category is [Done] as well
  • This issue is shown in the Board that is linked to the plan:

    Board Backlog showing the issue as part of Sample Sprint 2
  • However, this issue is missing from the plan:

    Advanced Roadmap Plan view listing 10 issues, but the example one is missing

Environment

Jira Software Data Center on any version from 8.0.0

Diagnosis

Empty Resolution field

  • The issue that is missing is in a "green" status (status from the 'Done' category), but does not have a resolution set (the resolution field is set to unresolved)

  • A way to find issues from the board that are missing from the plan because the resolution field is empty is to use the following JQL query:

    <Board_filter_JQL_Query> AND statusCategory = done AND resolution is empty

Empty Resolved Date

  • The issue that is missing is in a "green" status (status from the 'Done' category), has a resolution set (the resolution field is set to a value), but has no resolution date (the Resolved field is missing from the Dates panel)

    Issue Detail view of a story. The resolution field is set (marked with a red rectangle). The Dates panel (marked with a red rectangle) is only displaying a timestamp for Created and Updated. Resolved timestamp is not displayed.
  • Normally, if an issue is "correctly" resolved ( for example, via a workflow transition), both the Resolution field and the Resolved date field should have non-empty values

  • A way to find issues from the board that are missing from the plan because the Resolved field is missing from the Dates panel is to use the following JQL query:

    <Board_filter_JQL_Query> AND statusCategory = done AND resolution is not empty AND resolutiondate is empty

Cause

Empty Resolution field

If an issue is in a status that is categorized as "Done" while the Resolution field is not set, such an issue will not appear in the plan view.

This behavior is expected by design, and there is an open feature request meant to change this behavior, which is tracked in the public ticket linked below:

Empty Resolved Date

If an issue is in a status that is categorized as "Done" while the Resolution field is set but the Resolved field is empty, such an issue will not appear in the plan view.

This situation may happen if the Resolution field was set without using a workflow transition, but instead the Resolution field was set:

Solution

Empty Resolution field

Option 1: Add a post function to set the 'Resolution' field during a workflow transition

Modify the workflow transition that transitions to the completed status to automatically set the resolution field to a non-empty value by using the post-function Update Issue Field, and make sure to publish the workflow change.

Post-function details:

Update parameters of the Update Issue Field Function for this transition. Issue Field is Resolution, Field Value is Done

Post-function placement:

List of all post functions of a specific transition. The function "The Resolution of the issue will be set to Done" is the first (top) function.

This workflow change will ensure that the resolution field is set the next time an issue is transitioned to that Done status, and therefore, the issue will show in the plan view.

For issues that have already been transitioned to that status prior to the workflow change, you can transition these issues to a different status, and then transition them back to that status in order to set their resolution field.

Option 2: Adding a Dark Feature to allow 'Unresolved' issues to be shown on Plans

If modifying the workflow is not an option, you can instead enable a dark feature to allow the plan view to show issues in a Done status without the resolution set.

Important note about this dark feature:

  • This dark feature will only help with issues having an Empty Resolution Field

  • This dark feature will have no impact on issues with an Empty Resolution Date

Here are the steps to enable this dark feature:

  1. Log in as a Jira Admin

  2. Go to the URL <Jira_BASE_URL>/secure/SiteDarkFeatures!default.jspa

  3. Add the following dark feature

    com.atlassian.portfolio.issueloading.includeUnresolvedCompleted
  4. Make sure that the dark feature is listed on the page

Empty Resolved Date

  • If you use a Script to set an issue's Resolution field, you will need to fix the script to ensure that the Resolved Date field is also set. Please note that such customization falls outside of Atlassian Support Offerings.

  • If you use a rule from Automation for Jira to set the Resolution Field, you will need to set the Resolution field in the Transition Issue action instead of in the Edit Issue action, as illustrated below:

    A4J rule with action "Transition Issue", the Resolution field is set to Done.
  • Further, Option 1 (Add a post function to set the 'Resolution' field during a workflow transition) for the Empty Resolution Field can be applied here as well. Setting the Resolution field via a workflow transition will ensure that the Resolved Date field is set.

Updated on June 18, 2025

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