Troubleshooting playback issues (deteriorated quality or buffering)

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

Resolve Loom playback issues, poor quality, or buffering with these troubleshooting steps.

Diagnosis

Your video is buffering for a long time, frequently stopping, and/or you are seeing a drop in video quality.

Cause

Video playback can be affected by many different factors. Most playback issues are related to your ISP's (internet service provider) bandwidth and network latency. If you are using an older device this can also affect playback as video streaming requires significant processing power which older devices can be slower to handle. 

Solution

Troubleshooting steps 

We recommend trying out the following for initial troubleshooting:

  • Restart your router and modem Playback issues are oftentimes a result of poor internet connection. We recommend resetting your router or modem as this can reset your connection.

  • Update your browser Out-of-date browsers can hinder the playback quality. 

  • Disconnect from your VPN VPN can slow down your internet due to the time it takes to encrypt and decrypt data. VPN servers can also get overloaded and slow down our connection.  As a result, this can increase the buffering time when viewing videos.

  • Close excess browser tabs or applications Recommend closing out any other applications as these can make everything run slower. 

  • Clear your browser’s cache or try another browser Accumulated cache and cookies can interfere with the video playback. For this reason, we suggest trying a different browser or clearing your cookies and cache. 

If the steps above do not resolve the playback issues, your video could be corrupted. Feel free to reach out to our Support team here if you would like to further investigate. We cannot guarantee that we can fix the video but we will do our best to investigate.

Are you experiencing Audio and Visual lag?

If you are seeing lags in audio, we recommend checking out this article on troubleshooting and best practices. 

Updated on October 17, 2025

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