When selecting the filter icon button for a sprint, the JQL query doesn't return results
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When selecting the filter icon button from the backlog view to get the filter results of a sprint, the JQL results are empty and there is an error message stating "The option '####' for field sprint does not exist".
Diagnosis
To validate that the issue is what is described by this article, we can modify the JQL query to use the custom field ID value of the system sprint field. This entails the following:
Navigate to Settings > Issues > Custom Fields
Search for 'Sprint'
We should see two results returned here
If not, the issue is not what is described in this article
For the 'Sprint' field that is Locked, select the ... along the right side and choose View
In the URL for the view page you will see the custom field ID for the default sprint value.
For example you may see: <baseURL>/admin/ConfigureCustomField!default.jspa?customFieldId=10101. In this case the 10101 is the ID value for this field.
Once we have the ID value, navigate back to backlog view and select the filter icon button for the sprint.
Modify the prebuilt JQL that used for this operation to use the custom field ID rather than the 'sprint' word.
For example: "cf[10101] = ######" rather than "sprint = ######"
Where ###### is the sprint ID value for the sprint used in the original query.
If this returns the expected results using the ID value syntax then you are likely impacted by this situation described in this article.
Cause
This can occur if there is a custom field (of type select list) created with the name 'Sprint'. Since the 'Sprint' field is a default field added by Jira Software, if a select list custom field with the same name is created and the ID for the sprint doesn't appear in the options for the select list this error can be thrown.
If a custom field with the name 'Sprint' is created of different custom field types the JQL results may still be incorrect if the query is running against that field rather than the field in question, but the error from the JQL may different or there may be no error at all however the results may be incorrect.
Solution
To address this issue, the additionally created 'Sprint' custom field would need to be renamed. This can be done via:
Navigating to Settings > Issues > Custom Fields
Search for the 'Sprint' fields
Choose the ... for the field that is not the Locked custom field
Select Edit Details
Update the name field to be something other than 'Sprint'
Select Update
Was this helpful?