Users report "State mismatch!" error when trying to export Jira cloud issues to MS Excel or Google sheets
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
The error "State mismatch!" is seen in the UI when trying to export Jira Cloud issues via Microsoft Excel or Google Sheets from the Advanced Issue Search page.
Environment
Jira Cloud integrated with MS Excel or Google Sheets
Diagnosis
The issue may be specific to one user/machine or multiple users/machines
The error message may be seen when exporting issues via Excel or Sheets.
Cause
When a user exports Jira cloud data to Excel or Sheets, a WebSocket connection (WS) is established between the client and the integration addon. Once the connection is established, an OTP is shared to validate it. If there are issues with the WebSocket connection, it can result in the State Mismatch error.
The issue is also tracked under a bug ticket: API-539 - "State mismatch" while using "Open in Sheets" functionality.
Solution
Check if the same error persists when trying to export via Excel or Sheets in an incognito window on the browser. If the expected behaviour is seen in an incognito browser window, then the issue may be related to stale cache/session data. Please try clearing the browser cache/cookies.
If the error persists in the incognito window as well, please ensure that all browser extensions are disabled in the incognito mode as well (Follow the steps here for Chrome)
If the above steps did not help, try revoking access to Jira Cloud for Spreadsheets from this page https://id.atlassian.com/manage-profile/apps, if an entry exists and try again.
Check with your IT administrator or network administrator if there are any firewall rules or network blockers that may be restricting the creation of WebSockets (WS) between Jira cloud and the integration app. In a working scenario, the WebSocket (WS) calls should succeed with a response status code 101. This can be verified in your browser's console Network tab.
If the above steps do not help, please raise a ticket with Atlassian Support team here for further investigation.
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