User unable to authenticate with Slack
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Jira is connected to Slack successfully but one or many particular users are receiving OAuth-related error messages when attempting to configure the Slack integration in Jira. Attempting to re-configure the OAuth integration in Slack results in Jira not responding accordingly.
Environment
Jira 8+
Jira Server for Slack (Official) app
Diagnosis
Error messages similar to the following appear in atlassian-jira.log
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2022-03-14 09:25:50,905-0700 slack-client:thread-2 WARN user 127.0.0.1 /secure/ConfigureSlack.jspa [c.a.p.slack.util.ResponseMapper] Slack returned an unsuccessful response to conversations.info/channel: invalid_auth
Cause
Multiple entries for affected users exist in the database tables relating to Jira's Slack integration which can be confirmed with the following SQL statement:
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select * from "AO_B7D8D8_AOSLACK_USER" where user_key = '(username)'
There should only be one row returned in the results.
Solution
If multiple entries are returned, delete both entries with the following:
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delete from "AO_B7D8D8_AOSLACK_USER" where user_key = '(username)'
From there the affected user(s) will be able to successfully re-configure the integration between Slack and Jira.
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