User Name and User Avatars are visible in JQL from 'Issue Panel' search but not in 'Advanced Search'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Summary:

When you are passing JQL Query with a user field, say assignee = "Username", it is being changed to AAID "602XXXXXXXXXX" in the Advanced Issue search while Username and avatars are populated while searching the same user fields from the Issue panel search in the project. 

Advanced Issue search :

Advanced Issue search.

Issue Panel search:

Issue Panel search.

Environment:

N/A

Diagnosis

N/A

Cause

Our 'issue panel' search uses the new JQL editor, which shows simplified user values. We are still working on consolidating this new JQL editor with Advanced Issue Search and it will available soon. 

This feature is in Jira bucket list for improvement so that users would get the same experience of search from both search features(Advanced Issue search and Issue panel Search). You can read about it on Roadmap page

Solution

Will be available soon. Find more about it under the "Consolidated Search in JIRA" section at  Roadmap page.

Updated on March 10, 2025

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