Unable to view/add a user to the assignee field of issues in Jira cloud projects

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Unable to view/add a user to the assignee field of issues in Jira Cloud projects, in spite of all the permissions in place. 

Diagnosis

 The issue was due to an indexing/synching issue in Jira.

Cause

Indexing/synching issue in Jira.

Solution

Remove the user from the Jira default group and re-add to it, which triggers a sync, which resolves the issue.

Below are the steps to follow:

  1. Navigate to the user management page.

  2. Identify the product Jira software default group.

  3. Search for the user under the Users section.

  4. Remove the user from the default access group 

  5. Re-add the user to the default access group.

  6. This process will trigger a sync which resolves the issue. 

Updated on March 6, 2025

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