Unable to view/add a user to the assignee field of issues in Jira cloud projects
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Unable to view/add a user to the assignee field of issues in Jira Cloud projects, in spite of all the permissions in place.
Diagnosis
The issue was due to an indexing/synching issue in Jira.
Cause
Indexing/synching issue in Jira.
Solution
Remove the user from the Jira default group and re-add to it, which triggers a sync, which resolves the issue.
Below are the steps to follow:
Navigate to the user management page.
Identify the product Jira software default group.
Search for the user under the Users section.
Remove the user from the default access group
Re-add the user to the default access group.
This process will trigger a sync which resolves the issue.
Updated on March 6, 2025
Was this helpful?
Still need help?
The Atlassian Community is here for you.