Unable to Transition Issues after JIRA Upgrade Due to JIRA Suite Utilities Plugin
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
After a JIRA Upgrade, users are unable to transition issues (Resolve, Close, etc.) regardless of project permissions.
An error is presented stating "The JIRA server was contacted but has returned an error response. We are unsure of the result of this operation. Close this dialog and press refresh in your browser."
There are not necessarily any errors listed in
atlassian-jira.log.
Diagnosis
Check if the Suite Utilities for JIRA plugin was utilized in the older JIRA instance.
Cause
If this plugin was utilized on the older version of JIRA, then most likely JIRA has been upgraded with the same old version of this plugin. For instance, the older version of JIRA was 4.2 and used version 0.7.16 of the plugin and now after upgrading to JIRA 4.4, the same version of the plugin is being used.
Solution
Resolution
Review the version history to find a suitable version of the plugin for your specific version of JIRA
Update the plugin to the appropriate version
Was this helpful?