Unable to install or update Add-ons via UPM due to Invalid anti-XSRF token provided

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Universal Plugin Manager is unable to install new add-ons or update existing add-ons.

The following error message is displayed: "Invalid anti-XSRF token provided. The valid token should be retrieved transparently, but you may want to perform a hard refresh in your browser and try again before creating a support issue"

Diagnosis

JIRA is being accessed through a proxy server.

Cause

The proxy server appears to be introduce this error, but exact cause of this issue is currently unknown.

Solution

Workaround

Method 1:

Install plugin manually by file upload: Installing Marketplace apps

Method 2:

Bypass the proxy server and access JIRA directly to install plugins via the UPM.

Updated on April 2, 2025

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