Unable to Delete Workflow Due to MySQL Case Sensitivity

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Not able to delete an inactive workflow.

Cause

This is caused by the case insensitive issue in MySQL when dealing with "SELECT" statement. For more information, please see the MySQL documentation.

Resolution

  1. Create a JIRA XML backup data via Administration -> Import & Export -> Backup Data to XML.

  2. Stop JIRA.

  3. Create a new database with COLLATE utf_bin. For example:

    CREATE DATABASE jiradb CHARACTER SET utf8 COLLATE utf8_bin;

    Remember to ensure that jira's user is granted the appropriate privileges. See Connecting JIRA to MySQL.

  4. Configure JIRA to use the new database.

  5. Start JIRA.

  6. Restore the XML backup data.

Updated on September 25, 2025

Still need help?

The Atlassian Community is here for you.