Unable to create issues due to unsupported content in Jira Server and Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When trying to create an issue in Jira, it fails with the message:

We can't create this issue for you right now, it could be due to unsupported content you've entered into one or more of the issue fields.

The issue may or may not be actually created, despite the error.

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Environment

All versions of Jira Core 7.x and 8.x.

Diagnosis

The "unsupported content" message is the strongest lead in this issue. You may also check the logs to help in narrowing down where the failure is.

The following command should list the classes that threw the error during issue creation. It may help narrow down what plugins we should look for in the Solution section.

1 cat application-logs/atlassian-jira.log | grep "Error creating issue" -A30 | grep "at " | egrep -v "at com.atlassian|at com.sun|at javax.|at java."

The issue may or may not be created after the error. It depends if the error occurred in a workflow validation (before creation) or post-function (after creation).

Cause

This error is usually caused due to a workflow configuration — mainly Validations and Post-functions in the Create Transition.

It's also usually a validation or post-function provided by a 3rd party app that makes use of fields that may not be present in the issue. The log capture may help identify which app's failing.

Solution

The solution consists of reviewing the workflow.

  1. Edit the issue's workflow

  2. Open the Create transition

  3. Check if the are custom validators on the transition (aside from the "create issue permission" validator). Edit or remove them if necessary.

  4. Check if there are custom post-functions on the transition. Edit or remove them if necessary.

It's common that validations and post-functions make usage of fields that may not exist in the issue. You may edit the workflow or adjust the issue create screen (and project's field configuration) so the fields are present.

Updated on March 13, 2025

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