Unable to Change Authentication Methods in Jira.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After enabling modern auth (such as oAuth) and attempting to remove Basic Auth, it is possible to receive the error message:

"Could Not Change the Configuration Some Error Occurred"

(Auto-migrated image: description temporarily unavailable)

Environment

Any version of Jira. 

Diagnosis

You can even see entries such as this in your configuration files:

<com.atlassian.plugins.authentication.basicauth.block.requests>true</com.atlassian.plugins.authentication.basicauth.block.requests> <com.atlassian.plugins.authentication.basicauth.show.warning.message>true</com.atlassian.plugins.authentication.basicauth.show.warning.message>

That implies the configuration had been changed.

Cause

A potential cause for this is a load balancer, web application firewall, or proxy preventing the Jira instance from receiving the HTTP PATCH request, which is what is used to update the configuration files.

Solution

Temporarily bypassing or adding an exemption if you discover a load balancer, web application firewall, or proxy preventing this HTTP Patch Request will allow you to save the settings. 

Updated on March 13, 2025

Still need help?

The Atlassian Community is here for you.