The Sprint field contains completed Sprint valuesold

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

You might notice some inconsistent behavior with the Sprint field, while viewing a Jira issue from a Software project:

  • Scenario 1: the Sprint field contains the current Sprint the issue belongs to, in addition to the previous Sprints it used to be part of:

    Sprint field contains the current Sprint the issue belongs to.
  • Scenario 2: the Sprint field only contains the current Sprint the issue belongs to

    Sprint field only contains the current Sprint the issue belongs to.

The purpose is to explain the reason why Scenario 1 might happen and how to prevent it.

Root Cause

A Jira issue will contain multiple Sprint Values if it was moved from one Sprint to another while completing an Active Sprint, using the option Move open issues to <Sprint_Name>:

Jira issue that contain multiple Sprint Values.

This behavior is expected by design. The reason why the Sprint field retains the completed Sprint is because the Jira application is trying to maintain the history of where the Scrum Master planned to complete the issue but did not. It helps ensure that historic Sprint reports are accurate.

Solution

If you want to prevent Scenario 1 from happening (you want Scenario 2 to happen instead), you will need to move the Jira issue to another Sprint before closing the active Sprint the issue belongs to.

There are various ways to move an issue to another Sprint, and which will not retain the old Sprint value in the Sprint Field:

  • Method 1: Go to the Backlog page, right-click on the issue, select the option Send To, and select a target Sprint

    "Send to" option with more than one sprint.
  • Method 2: Go to the Backlog page, drag and drop the issue from a Sprint to another

    Drag and drop issue between sprints.
  • Method 3: Open the issue from the View Issue Screen, click on the Sprint field to edit it, and set the new value

    Edit sprint in the Issue view.

Updated on March 10, 2025

Still need help?

The Atlassian Community is here for you.