The ResourceConfig instance doesn't contain any root resource classes error in logs

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following appears repeatedly in the atlassian-jira.log:

1 2 3 4 5 6 7 8 9 10 11 12 2013-03-13 16:48:39,719 http-bio-8080-exec-2 ERROR matheus 1008x362x1 rb7xtz 0:0:0:0:0:0:0:1 /rest/stp/1.0/license/status [server.impl.application.RootResourceUriRules] The ResourceConfig instance does not contain any root resource classes. com.atlassian.util.concurrent.LazyReference$InitializationException: com.sun.jersey.api.container.ContainerException: The ResourceConfig instance does not contain any root resource classes. at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:152) at com.atlassian.util.concurrent.LazyReference.get(LazyReference.java:115) at com.atlassian.plugin.servlet.DefaultServletModuleManager.getFilter(DefaultServletModuleManager.java:389) at com.atlassian.plugin.servlet.DefaultServletModuleManager.getFilters(DefaultServletModuleManager.java:213) ... Caused by: com.sun.jersey.api.container.ContainerException: The ResourceConfig instance does not contain any root resource classes. at com.sun.jersey.server.impl.application.RootResourceUriRules.<init>(RootResourceUriRules.java:99) at com.sun.jersey.server.impl.application.WebApplicationImpl._initiate(WebApplicationImpl.java:1298) at com.sun.jersey.server.impl.application.WebApplicationImpl.access$700(WebApplicationImpl.java:169) at com.sun.jersey.server.impl.application.WebApplicationImpl$13.f(WebApplicationImpl.java:775)

Cause

This problem happens due to a bug in version 3.0.25 of the Support Tools Plugin (JRA-32094/STP-233).

ℹ️ This version of the plugin has already been pulled from release

Resolution

Update the Support Tools Plugin to a newer version:

  1. Navigate to the Manage Add-ons page;

  2. Click 'Upload Add-on' link;

  3. Paste the following link:

    1 https://marketplace.atlassian.com/download/plugins/com.atlassian.support.stp/version/30543
  4. And hit Upload.

Alternatively, uninstall the plugin from the Manage Add-ons page directly, and if that is not possible, please:

  1. Shutdown JIRA applications;

  2. Remove the *.stp-3.0.25.jar from the $JIRA-Home/plugins/installed-plugins.

    ℹ️ The full filename will be something like: plugin.1481569806231700576.stp-3.0.25.jar

  3. Restart JIRA applications.

ℹ️ This will not remove the Support Tools functionality. This will simply cause JIRA applications to revert back to the default bundled version of the plugin.

Updated on April 8, 2025

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