The Resolution field can't be updated when transitioning or closing a case from a specific status
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When attempting to resolve an issue, the Resolution field cannot be filled because the option to do so is not visible.
Environment
Jira Software v8.x and above.
Diagnosis
You should confirm whether any post function is setup to update the issue field:

Check if any new transition ID is created specifically for the affected transition (e.g., from "In Progress" to "Close").
In the following example, you will see a transition "Closed (81)" mapped for "Work in Progress."
For other statuses, a transition "Mark as Done (61)" is mapped:

Cause
Multiple transitions with unique IDs are mapped between specific state transitions.
Solution
Solution 1 :
Delete the transition "Closed(81)" and reuse the "Mark as Done(61)" transition for affected status:


Solution 2 :
Select the closed transition between work in progress to closed. Select the Transition view screen as resolved screen of the affected project:


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