The development panel times out on the issue view in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Development Panel (or dev panel) times out and doesn't show commits or branch information on the issue screen.

Environment

Jira 7 and 8 connected to a DVCS through an Application Link.

Diagnosis

The development panel doesn't show information and may exhibit a timeout error.

On Jira's atlassian-jira.log we can see the below message when trying to load the development panel information:

1 2020-10-23 12:20:43,069-0400 http-nio-8080-exec-8 WARN username 740x22498x2 dxiq8v 10.123.123.10 /rest/dev-status/1.0/issue/detail [c.a.j.p.devstatus.provider.DefaultCoordinator] name-of-the-application-link-dvcs (timeout after 10000ms, not getting from cache)

Cause

The DVCS integration from the development panel has a default timeout of 10 seconds (10,000 ms).

If the issue's specific data is too large, this may not be enough for the DVCS application to respond and results in timeout.

Solution

We may increase the timeout for the devstatus connections to allow larger requests to complete successfully.

The below parameters should be added to Jira's JVM:

1 2 3 -Djira.devstatus.coordinator.timeout.summary=30000 -Djira.devstatus.coordinator.timeout.detail=30000 -Djira.devstatus.capability.connection.timeout=30000

In the example above, we're setting the timeouts to 30 seconds. You may increase this values if needed.

Updated on March 17, 2025

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