Resolve missing tabs on view issue screen in Jira Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.
Summary
When adding multiple tabs to a screen associated with View Issue, the tabs don't show up as expected. If the same screen is used for the Create Issue take action on it displays as expected.
Diagnosis
A tabbed screen has been defined for the View Issue screen.
There are multiple custom fields involved.
Cause
Specific custom fields are assigned to various places on the View Issue screen:
Date custom fields will show up in the Dates section.
Any custom fields involved with a user picker will show up in the People section.
If a custom field doesn't have any data in it, it will not be rendered.
If there are no custom fields that meet either of the above conditions, the tab will not show up.
If just one tab has custom fields filled, it will not be represented, and the fields from this tab will be rendered at the Default Field Tab.
If you set this property, jira.permission.edit.group = group_name on the workflow status, the tab will not show up.
The empty custom fields and tabs are hidden on the "View issue" screen to enhance readability and performance. This ensures only relevant information is visible, preventing clutter from numerous custom fields.
Solution
Ensure that the following conditions are met:
All of the tabs have custom fields on them (including the default Field Tab).
At least one of those custom field types must not be a Date or People type (as those will show up in their respective sections in the view issue screen).
At least one of those custom fields must have a value OR be set to be shown when empty.
At least two tabs (including the Default Field Tab) should have Fields filled OR set to be shown when empty (other than System Fields such as Summary, Description, Labels, Priority, and Issue link).
Use this property jira.permission.edit.group = group_id, which should work as expected.
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