Some issue types are missing when creating a new Jira issue from the the Board view
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The purpose of this article is to list the most common reasons why some issue types are missing when creating a new Jira issue from a Board, via the Create issue button located at the bottom of the Backlog (or at the bottom of a Sprint), and how to identify them.
Environment
Jira Software Data Center on any version from 8.0.0.
Diagnosis
Check the issue type that is missing from the Create Issue button from the Backlog panel:
If the only issue type that is missing is the Epic type, then it is expected behavior by design
Please refer to the Root Cause 1 section for more details
Go to the Board configuration page and check the filter query:
If the filter query includes only specific issue types, then Root Cause 2 is relevant.
Example JQL: "Project = SCRUM AND issuetype = BUG"
If the filter query is not excluding any issue type, but there is an OR operator with an issuetype condition on 1 side, then Root Cause 3 might be relevant.
Example JQL: "project = SCRUM AND (component = Component1 OR issuetype in (bug))"
Go to the board and try to create a new issue in the top Sprint panel, or in the Backlog panel:
If you see that the issue type dropdown is cropped in the UI, then Root Cause 4 is relevant.
Cause
Root Cause 1 - The missing issue type is Epic
Issues of type Epic cannot be created in the backlog. This is expected by design. Instead, Epics need to be created via the Epics panel located on the left side.
Root Cause 2 - The board filter query is excluding some issue types
If the board filter is configured to only include specific issue types, it will only be possible to create new issues from the backlog that belong to these types. This behavior is expected by design.
Root Cause 3 - The board filter query is not excluding any issue type but we are hitting a Jira bug
The Backlog Create Issue button may exclude some issue types, depending on the Board filter query, even if the query does not explicitly exclude them. For example, if the filter query uses an OR operator with a condition relying on the issue type on either side, the Board will incorrectly interpret this filter and exclude issue types by mistake.
This behavior has been reported as a bug: JRASERVER-73245 - Creating issues Inline on the backlog view does not respects issue types restrictions.
Root Cause 4 - The issue type dropdown is cropped due to a Jira bug
Depending on how many issue types are available on the board, the issue type dropdown might end up being cropped at the top when creating an issue either from the top Sprint panel or from the Backlog panel.
This behavior is tracked in 2 bugs:
Solution
Solution for Root Cause 1
To create an Epic from a board, hover over the EPICS panel on the left. A "+" sign will appear, and clicking it will trigger the pop-up screen to create an Epic.
Solution for Root Cause 2 and 3
Edit the Board filter query by removing the issue type condition, or by including more issue types.
Solution for Root Cause 4
For this scenario, the only way to create new issues for the missing issue types is to create them outside the board, for example via the Create button from the Top Bar menu.
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