Service-specific error code 4 when starting Jira service in Windows
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After following the instructions on Running Jira applications as a Windows service page, or after upgrading the instance, Jira can't be started with "service-specific error code 4".
The following appears in the Windows Event Log:
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2
The "Jira" service terminated with service-specific error
The system cannot open the file.
Environment
Jira Server
Windows OS
Diagnosis
Ensure that Jira is running on supported platforms
Check the article Problems installing Jira as a service on Windows 64bit to see if there's an issue with an incompatible Tomcat applet type
Cause
When executing the command "service.bat install Jira"
, the Command Prompt console was not run as an Administrator account. This causes the Jira service to be installed without sufficient privileges for accessing the required files. This can also be caused by the service logon account not having enough permissions to start the service, especially if it's set to a network service account.
Solution
Resolution
Run the cmd (Command prompt) as Administrator and remove the currently installed service with the command:
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service.bat remove Jira
Note: If the service name was customized, you might need to update the command, navigate to the service in Windows, i.e. 'Control Panel' -> 'Administrative Tools' -> 'Services' and locate "Atlassian Jira"
On the Administrator command prompt, follow the instructions to Running Jira applications as a Windows service
If the issue persists: Open the service properties, go to the log-on tab, and change the option to Local System Account
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