Rest endpoint to get filter columns no longer works

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When using URL /rest/api/2/filter/{id}/columns gives the error 404. 

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Environment

  • 9.x

  • Newly created saved filter

  • Existing saved filter

Diagnosis

As documented in REST API, the REST API call will return a 404 error if the filter does not have any columns.

Cause

A newly created filter will use My Defaults settings for the columns. In order for the REST API call to work, you will need to switch it to the Filter columns so that the Issue Filter will have its own settings for the columns. There is a detailed explanation of the filter columns in Configuring the default issue navigator - Atlassian Documentation.

Solution

  • Go to the Issue search page and choose your filter.

  • From the top right side switch to List View.

  • Then click on Columns drop down.

  • There switch the Columns to Filter section and select the columns you want to display and click Done.

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Updated on March 10, 2025

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