Resend Invites shows a Locked Icon

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

As a User Admin role, you are unable to resend invites to users as the option is greyed out and showing a lock icon:

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Environment

This article only applies to cloud Admin Hub customers (admin.atlassian.com)

Cause

This is an expected behavior from our Admin Hub level, as the user access admin role is meant to allow these admins to manage user's access to products but not manage users on an organizational level.

In AdminHub (admin.atlassian.com) the system will not distinguish between what users have been invited to (e.g. their Confluence, Jira...) and since user access admins are not intended to manage users across the board (only their access to specified products), they are not given permission to resend invites to users.

In summary, the system will not verify what each user has been invited to. So, to avoid user access admins resending invites for products they don't control, the system will lock the resend invite functionality for this role.

Solution

You will need to get Organization Admin role assigned to your user in order to be able to resend invites.

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Updated on April 8, 2025

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