Can't submit ticket via issue collector "There was a problem submitting your feedback, likely due to the configuration of this form."

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When a user tries to submit a ticket via linked to the issue collector and gets this error:

Oops! Something went wrong... There was a problem submitting your feedback, likely due to the configuration of this form. You might want to contact the site owner to let them know about this issue.

Diagnosis

There could be a few reasons why the issue collector might be showing this error. To investigate, navigate to the project settings > Issues > Collectors and check for errors. If you notice the error below, this article is for you:

Issue Collector Errors

Required fields not present or fields too long in collector 'issue collector XXX' invoked from '10.10.10.10' by Anonymous.

Cause

By design, if a field is already Required in the Field Configuration and a new Issue Collector is created, the field will auto-populate. Creating an issue collector and then adding Required fields might cause a field to be missing from the Issue Collector view. 

Verifying the Field Configuration of the project, there are mandatory fields that are not added to the view of the Issue Collector. The configuration will prompt for that problem before saving it with the following warning:

The issue type you've chosen requires fields other than 'Summary' to create issues. Only custom templates can be created since 'Raise a bug' and 'Got feedback?' will not be able to populate other required fields.

Solution

To solve this issue, find the mandatory field for the specific issue type and add it to the issue collector. Mandatory fields are marked as Required in the Filed Configuration Schemes - check this page for more info.

Once the Required field is found, it must be selected with a checkbox in the Issue Collector configuration and then save the configuration.

Pro tip:

The quickest way to find the mandatory fields is by initiating a creation of a ticket from the affected issue type from the Create button and look for the fields marked as required with a red *.

Important info from Use the issue collector page: 

Not all fields of types of fields can be added to the form, since some fields cannot be displayed to anonymous users. The fields types that can be displayed are:

  • Standard Fields: Summary, Description, Components, AffectsVersion, Environment, Priority, Attachment

  • Custom Field Types: Date Time, Radio Buttons, Multi-Checkbox, Multi-Select, Number, Select List, URL field, Version Picker, Cascading Select, Project Picker, Single Version Picker, Text Field, Free Text Field

Updated on March 3, 2025

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