Resolve 'Irrelevant' Category Issue in Jira Pie Charts
Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When configuring a pie chart and selecting a field in the "Statistics Type" parameter (for example, selecting a "Status"), the resulting pie chart contains the category "Irrelevant", but the source field does not contain this value.
Diagnosis
Check the field configuration and results for the field you selected as the "Statistic Type" and confirm that it does not have the value "Irrelevant".
Cause
Multiple Custom fields with the same name
Multiple custom fields have the same name as the one picked up in "Statistics Type" or names that duplicate those of a standard Jira field.
ℹ️ For example, there might be a custom field named "Status," which is picked in the pie chart configuration instead of the native status field (which contains the issue status). Generally, the "Irrelevant" category in the statistics widget appears automatically if issues in the configured filter don't have any data for the statistics type selected.
The field is hidden
The relevant field has been hidden in the project's Field Configuration scheme.
The field is unavailable
The field selected for the gadget's "Statistics Type" is unavailable to some or all of the issues returned by the configured filter.
Solution
Multiple Custom fields with the same name
Workaround
Examine all available entries in the "Statistics Type" field and pick another entry with the same name. Note that the entries are not alphabetically sorted (this is a known issue JRASERVER-61819 - Order Gadgets Configuration Alphabetically).
Solution
Rename conflicting custom fields and make sure their names don't duplicate each other or those of standard fields. When each field has a unique name, picking it up in the "Statistics Type" is easy, as it should be possible to just type in the full custom field name in the selector to make it select it automatically.
The field is hidden
Unhide the relevant field from the project's Field Configuration scheme.
The field is unavailable
Either adjust the filter to exclude issue types/issues from projects that don't have the "Statistics Type" field available, or adjust the custom field context to add this field to the affected project/issue type.
Was this helpful?