Perforce Job Integration Stopped Working

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

The integration stopped working. Only some of the JIRA issues are copied to Perforce as "perforce jobs".

The following appears in the atlassian-jira.log

1 2 3 4 5 2016-09-06 20:02:35,639 http-bio-8080-exec-272 ERROR admin 1234x3633456x2 z9kz76 12.3.456.78,910.111.22.33 /secure/QuickEditIssue.jspa [jira.event.issue.IssueEventListenerHandler] Exception thrown invoking listener [com.atlassian.jirafisheyeplugin.perforce.listener.JobUpdateListener] : Cannot cast com.atlassian.jirafisheyeplugin.perforce.PerforceManagerImpl to com.atlassian.jirafisheyeplugin.perforce.PerforceManager java.lang.ClassCastException: Cannot cast com.atlassian.jirafisheyeplugin.perforce.PerforceManagerImpl to com.atlassian.jirafisheyeplugin.perforce.PerforceManager at java.lang.Class.cast(Class.java:3369) at com.atlassian.jira.plugin.OsgiServiceTrackerCacheImpl.getOsgiComponentOfType(OsgiServiceTrackerCacheImpl.java:73) at com.atlassian.jira.ComponentManager.getOSGiComponentInstanceOfType(ComponentManager.java:713)

Diagnosis

  • The configuration of the Perforce with Jira was performed as described in the Atlassian KB Create a Perforce Job when creating a JIRA issue;

  • There is no duplicate Fisheye plugin (jira-fisheye-plugin-xxx.jar) in the $JIRA_HOME\plugins\installed-plugins folder.

    đź’ˇOn Unix, you can check this by running the command:

    1 ls -la $JIRA_HOME\plugins\installed-plugins

Cause

We have identified two possible causes that can cause this error:

  1. Corrupted plugin cache; or

  2. Expired password for the service account that runs the p4web process

Solution

Resolution

Cause 1:

To clear the plugin cache, it is required to restart your Jira instance.

Cause 2:

Change the password expired password for the service account that runs the p4web process. Please, refer to the Perforce documentation for further details: Passwords and P4Web and Passwords and Authorization.

Updated on April 2, 2025

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