Linked issues in Jira Data Center are showing as failed to load.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Viewing Jira issues that have references to other issues connected via application links are showing as 'Failed to Load'.

Environment

Jira instances connected via application links.

Diagnosis

Reviewing the atlassian-jira.log, you can find log entries that display the error 'No Application link found for the given Application Id:

1 2021-06-21 09:35:16,687-0400 https-jsse-nio-8443-exec-133 url: /rest/viewIssue/1/remoteIssueLink/render/101357; user: chris ERROR chris 575x150555x3 1nzw8zh 10.10.229.22,10.128.254.78 /rest/viewIssue/1/remoteIssueLink/render/101357 [c.a.j.p.v.issuelink.rest.RemoteIssueLinkResource] Error occurred while generating final HTML for remote issue link: java.lang.IllegalArgumentException: No Application Link found for the given Application Id: d70487e9-d20e-3ec3-836e-d33e3054f84a

Cause

Each application link has a unique ID. In this case, the application ID changed due to a Jira upgrade.

Solution

Recreate the application link to rebuild the connection and update the Application Id's.

Recreating an application link doesn't remove any data. Existing macros, plugins and pages that make use of an application link will start working again once the application link has been recreated.

Updated on March 20, 2025

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