Jira Service Management shows 500 error on Help center / customer portal

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you try to load the help center or portal of any Jira Service Management project, a 500 error is shown:

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Diagnosis

The support team can see the following error message in the logs at their end:

1 There are application links of type interface com.atlassian.applinks.api.application.confluence.ConfluenceApplicationType configured, but none are marked as primary

You can confirm if you are hitting this issue by going to your Jira application and navigating to Products > Application links. If you have added a link to any Confluence application, it could be on the same Cloud site or any other Confluence site, and if the application is not marked as "Primary" then you are hitting this issue.

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Cause

The error suggests that there is a Confluence application linked to this Cloud site but it is not marked as a primary app link. 

Solution

You can follow the below procedure to mark the Confluence application as primary. 

  1. On your cloud site go to the Jira application and navigate to Products > Application links 

  2. Find out the application id of the Confluence application linked to your Jira site that is not marked as primary from this page. You can find the application link id in the URL when you try to edit any application link

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  3. You need to send the following POST action using a CURL command OR any REST API client like Postman:

    1 2 3 4 Method: POST Endpoint: https://<CloudSiteURL>.atlassian.net/rest/applinks/3.0/applicationlink/primary/<ApplicationIdOfConflunceApp> Referrer: https://<CloudSiteURL>.atlassian.net/plugins/servlet/applinks/listApplicationLinks Authorization: Basic <base64of Email:APItoken>
  4. You will receive a 200 response with a message saying that "Application with id '<ApplicationIdOfConflunceApp' is now the primary application of its type"

Feel free to reach out to Atlassian support in case you face any issues performing these steps by raising a ticket here.

Updated on March 10, 2025

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