Jira server throws Your account was suspended error when refresh GitHub repository list

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

The following appears in the atlassian-jira.log:

2014-07-14 14:24:56,089 http-bio-8081-exec-8482 ERROR npetrovic 864x102465x95 a5qbvb 74.121.196.166,0:0:0:0:0:0:0:1 /rest/bitbucket/1.0/organization/1/syncRepoList [common.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service com.atlassian.jira.plugins.dvcs.exception.SourceControlException: Error retrieving list of repositories at com.atlassian.jira.plugins.dvcs.spi.github.GithubCommunicator.getRepositories(GithubCommunicator.java:164) at com.atlassian.jira.plugins.dvcs.service.remote.CachingCommunicator.getRepositories(CachingCommunicator.java:169)
Caused by: org.eclipse.egit.github.core.client.RequestException: Sorry. Your account was suspended. Please contact enterprise@github.com (403) at org.eclipse.egit.github.core.client.GitHubClient.createException(GitHubClient.java:516) at org.eclipse.egit.github.core.client.GitHubClient.get(GitHubClient.java:662) at org.eclipse.egit.github.core.client.PageIterator.next(PageIterator.java:173)

Diagnosis

First, check if the account is not really suspended (see here). If not, then this knowledge base article is probably what you need to do in order to get it working again.

Cause

The culprit is the OAuth key in the DVCS setup. The account that was suspended was the user who's OAuth key was used to setup the DVCS connection in the first place.

Solution

Resolution

Verify if the user set in your configuration has access to GitHub, and if not, try to create this connection again using a user with access there and see how it goes.

This will remove the information in the issues, but as soon as the sync is working, the data will be back to JIRA.

Please note

  • When adding a new Organization account, the repositories from this Organization will be added by the sync following a sequential order.

Updated on September 26, 2025

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