Jira "Search for issues" screen gets frozen when scrolling from one issue to another
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Jira "Search for issues" screen is freezing when scrolling from one issue to another
Environment
Jira Server / Data Center
Diagnosis
A very strange behavior can occur while scrolling issues on the "Search for issues" screen in Jira.
DB Integrity check and a Full Re-index performed without any luck;
Thread Dumps and Disk speed test: No performances issues are detected on the instance;
The issue happens even if it deletes the browser's history and cache;
The issue occurs on different browsers from different workstations and different users and in Incognito mode;
Customer does not use Announcement Banner;
All plugins are working as expected;
There is no "false" entry in pluginkey in the pluginstate table;
All plugin's cache are cleared;
Even in Safe Mode the issue persists;
HAR file does not give any clues, any HTTP response / request errors;
While reproducing no changes at all were added to atlassian-jira.log;
While reproducing no changes at all were added to atlassian-jira-sql.log after enabling this log;
Changing the Project type to Business then put it back to Software in order to refresh the metadata of the Project, does not fix;
The issue could happen in a single Project only, or in several Projects, or simply in all of them;
All the workarounds in the BUGs related to similar issues in JAC, does not fix it;
With a XML Restore, while reproducing it, it's possible to find out that only specific issues causes the page to freeze, and not all of them. ( Good hint here )
Cause
The problem is caused by customer's scripts in the fieldlayoutitem table. At least 1 one script embedded in field configuration can cause this problem.
Only the Projects that have this script in the fieldlayoutitem table, will face this issue. Projects that do not have this script in the fieldlayoutitem table, does NOT face this issue.
Due to the number of scripts that could be in the fieldlayoutitem table, it might be not something that can be easily found from the front end;
The issue could also happen after an upgrade, since it's common for the development team to change some front end code for both improvement and bug fixes. So this problem could happen because their script refers to the code that has been changed in the recent version of Jira.
Workaround
Disable "Enable HTML in field descriptions and list item values" to prevent the problem from happening.
This can be done from the Administration > System > General configuration > Edit Settings > Check OFF for "Enable HTML in field descriptions and list item values".
Solution
Evaluate all the scripts embedded in the field configuration and perform some tests based on trial & error to identify the exact script which is causing the problem.
Atlassian Support does not support to fix scripts since it's outside of support scope.
Was this helpful?