Jira plug-ins are shown unknown when checking compatibility
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Some Jira plugins (apps) are shown unknown when checking Jira upgrade compatibility for apps.
Environment
Versions: Jira 8.5.x
Insight app, Proforma app
Diagnosis
When checking plugin compatibility for upgrades, some apps may be reported as "unknown version compatibility", such as:
querydsl - this is an Atlassian internal system plugin and it will be updated automatically by the upgrade process
Proforma- the version you have may not be on Marketplace anymore (which is why it can't give you compatibility status), you will need to upgrade it manually to a compatible version (or the latest version)
Insight- also needs to be upgraded manually, see instructions here
Cause
The failure to obtain compatibility status may be due to:
plugin changed from User category to System app between Jira versions
app version is no longer present in Marketplace
apps like Insight or Advanced Roadmaps which changed from third-party status to bundled application status
Solution
Verify which version you have and the target version should be the latest one supported both in your existing Jira version as well as the upgrade planned Jira version. The apps can then be upgraded between these two Jira versions either before or after Jira upgrade. For additional information, contact support.
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