Jira issues generated via the issue collector do not appear in the current list of recent issues within the issue collector.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When a user creates an issue from the issue collector, this issue should show in the Recent Issues  section of the Issue Collector administration page, as illustrated below:

(Auto-migrated image: description temporarily unavailable)

In some situations, issues that were recently created by the Issue Collector might not appear in the recent issues list. The purpose of this article is to describe a scenario where issues are missing from this list, and how to fix it.

Environment

Jira Data Center on 9.0.0 any higher version.

Diagnosis

Run the following JQL query and verify and check if the issues that are missing from the "Recent Issues" list are found in the query result, after replacing <project-key> with the project key and <collectorId> with the collector ID which can be found in the URL while viewing the Issue Collector in the UI:

Please replace the placeholder values

1 project = <project-key> AND labels = "collector-<collectorId>" AND created >= "-30d"

If the issues that are missing from the "Recent Issues" list are not found in that JQL query, then open this issue in the View Issues page and check the labels field. If this field does not contain the label collector-<collectorId>, then this KB article is relevant and you can move on to the Solution section.

Cause

When an issue collector generates an issue, it should automatically assigns a label to the issue with the format collector-xxxxxxxx (where xxxx represents the collector id). Only the issues which have this label will be listed in the "Recent Issues" section of the Collector. By default, the Labels field is included in the Create Issue screen from the screen screen scheme associated to the project. If the Labels field is not visible/configured on this screen (as illustrated in the screenshot below), the label collector-xxxxxxxx will not be added to issues created by the Collector, and such issues will be missing from the "Recent Issues" section:

(Auto-migrated image: description temporarily unavailable)

Solution

To resolve this issue, include the Labels field on the create issue screen for the relevant project

Updated on March 18, 2025

Still need help?

The Atlassian Community is here for you.