Jira fails to start with UnsupportedClassVersionError in the logs
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
After upgrading an App (plugin), Jira may fail to start when it's next restarted and report an "UnsupportedClassVersionError" error in the logs.
This may also happen if changes are made to the environment (Java version or startup commands), though it's most common after an App upgrade.
Environment
Any version of Jira Data Center or Server.
Diagnosis
Jira will fail to start and an "UnsupportedClassVersionError" message will appear in atlassian-jira.log located at jira-home-folder/log/.
The message may contain additional details indicating that the App "has been compiled by a more recent version of the Java Runtime":
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2022-08-03 14:08:15,595-0400 localhost-startStop-1 ERROR [c.a.jira.startup.LauncherContextListener] Unable to start JIRA.
java.lang.UnsupportedClassVersionError: com/keplerrominfo/jira/commons/gadget/impl/ao/KRSSecurityEntry has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
Cause
The installed or upgraded App is incompatible with the Java version Jira's running on.
For example, "class file version 55.0" is for Java 11, while 52.0 is for Java 8.
For reference: Java releases
Solution
Solution 1
The main strategy is:
Stop all Jira nodes
Manually uninstall or revert the apps in the file system (both local and shared home folders)
Start Jira
Install a previously working version of the apps (if they were just removed and not replaced in step #2)
Contact the app vendor for further support
You may list the most recently installed/updated apps by listing the files under both the local and shared home /plugins/installed-plugins folders:
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$ ls -lath jira-LOCAL-home/plugins/installed-plugins
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$ ls -lath jira-SHARED-home/plugins/installed-plugins
You may delete the most recent files (listed at the top with the "lath" ls
parameters) or delete them and copy the jars from previous versions (from a similar non-upgraded environment maybe).
To install a specific older version of those apps, you may browse all the Apps versions at marketplace.atlassian.com (Automation for Jira screenshot just as an example):

Then right-click on the Download version you know to have worked and Copy Link Address:

Lastly, paste that app download URL into the Upload app from Manage apps admin interface:

Solution 2
Upgrade Java Runtime to a version which is both compatible with the Jira Supported platforms and the app/plugin.
Reference: How to change the Java version used by Jira
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