Jira cloud for Excel add-in doesn't load data, JIRA.JQL formula changes

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

The Jira Cloud for Excel add-in does not load in the desktop version of Microsoft Excel.

Sometimes, all cells that previously had =JIRA.JQL() suddenly appear as =_xldudf_JIRA_JQL. Trying to add the correct formula text back in results in a "#NAME?" error.

Environment

Microsoft Excel desktop version with the Jira Cloud for Excel add-in installed.

Diagnosis

Verify if the Office 365 version is the latest. Update it if possible.

Cause

This can happen randomly or whenever there is an upgrade to Office 365 or Windows.

However, uninstalling and reinstalling the add-in does not fix the load issue for your Jira data.

Solution

Revoke and reconnect Jira Cloud and Excel desktop

We will need to revoke access from Jira Cloud for the "Spreadsheets app" from the apps page in your Atlassian profile.

  1. Visit https://id.atlassian.com/manage-profile/apps

  2. Find "Spreadsheets app" in the apps list

  3. Select Remove access

  4. Follow our article to integrate Jira Cloud with MS Excel to reconnect the add-in to Jira

This would revoke the token, and then the next time the user tries "Get Jira Data" you'll be asked to re-authorize.

If using Excel Desktop it may be necessary to clear the add-in cache by following the steps below:

  1. In Microsoft Excel, select File -> Options

  2. Select Trust Center -> Trust Center Settings -> Trusted Add-ins Catalogs

  3. Mark the option Next time Office starts, clear all previously-started web add-ins cache

After reopening Excel Desktop, the add-in interface will loaded successfully.

Updated on May 12, 2025

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