javax.mail.AuthenticationFailedException: Database engine error: Version store out of memory
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
JIRA's incoming mail handler is failing to create any issues. The following error messages could be found in the log files:
1
2
3
4
5
6
7
2013-06-04 10:07:16,775 ERROR [XX XX] QuartzWorker-0 ServiceRunner
Create Issue/Comment Service for XXXX Create Issue/Comment Service for XXXX[10180]:
Error connecting to host 'xxx.xxx.xxx' as user 'xxxx' via protocol 'pop3': javax.mail.AuthenticationFailedException: Database engine error: Version store out of memory.
javax.mail.AuthenticationFailedException: Database engine error: Version store out of memory.
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:208)
...
Diagnosis
The usage of Microsoft's Exchange email server as the incoming mail handler.
Cause
FROM MICROSOFT'S Knowledgebase Article :
"This Warning event indicates that the ESE version store has reached its maximum size because of an unresponsive transaction. Updates to the database are rejected until the long-running transaction is omitted or rolled back. You may also receive an MSExchangeIS event 1022 that will provide the name of the database that reported a logon failure.
The ESE version store is where the Information Store service keeps records of transactions that are not yet finished, giving ESE the ability to track and manage current transactions."
Solution
Resolution
As this is a Microsoft Exchange-specific error, please refer to the article here, the User Action section: http://technet.microsoft.com/en-us/library/bb218441%28v=exchg.80%29.aspx for a list of steps to be taken in order to resolve this problem.
Was this helpful?