Issue is not updated by Post Function

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

A Post Function added to a transition does not appear to affect the issue.

Diagnosis

Reindexing, or directly viewing the issue, will cause the change made by the Post Function to appear.

Cause

This is caused by the Change Issue Field Post Function occurring after the Reindex Issue Post Function.

Solution

Resolution

  • Resolve this issue by ensuring that the Change Issue Field Post Function occurs before the Reindex Issue Post Function

    ℹ️ More information can be found here: Configuring Workflow

Updated on April 2, 2025

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