Invalid Start Time when entering worklog using Timetracker for Jira app Page

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Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When using Timetracker - Time Tracking & Reporting for Jira, an error Invalid Start Time/Invalid End Time is observed on updating Worklog entries using plugin Timetracker - Time Tracking & Reporting for Jira Plugin Page

Environment

  • Jira v9.3.1

  • JDK 9 or higher

Diagnosis

  • When entering Worklog on the Timetracker - Time Tracking & Reporting for Jira Plugin page, a validation error is observed: "Invalid End Time." This is observed since the time entered contains am/pm in lowercase.

  • On navigating to the > System> Look and Feel, the Time Format also shows in lowercase (for example, "am").

Cause

The issue is specifically observed when the locale Settings is set as en-GB and Jira is using JDK 9 and above.

1 2 <user.country>GB</user.country> <user.language>en</user.language>

As per JDK 9 Release Notes, there are changes starting JDK 9 where default locale data uses data derived from the Unicode Consortium's Common Locale Data Repository (CLDR). The AM/PM symbol for default locale is in small case as per the CLDR for Locale en-GB which can be verified here

Bug Report: SimpleDateFormat outputs AM and PM as lower case cover for more details on related behavior

Solution

The workaround is to add below JVM argument so that locale data is retrieved in the same way as in JDK 8 versions

1 -Djava.locale.providers=COMPAT,CLDR

To set JVM arguments, please refer Setting properties and options on startup

Updated on March 13, 2025

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