Remove Visibility Restrictions on a Jira Software Data Center Board

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

On the Recently visited boards or All boards page, located by going to Boards > View all boards, my board's visibility shows as RESTRICTED.

Cause

Your board is restricted due to viewing restrictions on its filter.

Recently, the display of board visibility on the Boards dashboard in Jira Software was updated. However, this did not affect which users have access to a board; it simply made it clearer to discover whether or not a certain board was restricted from the dashboard, in line with our other products.

Steps to Change Board Visibility

To remove the restrictions and change the visibility of your board to All Users, use the following steps:

  1. Click on the three dots (⋯) to open the Options menu, then choose Configure.

  2. The board's configuration appears. Click the Edit Filter Shares link.

  3. The edit filter screen appears. Next to Add Viewers, select Any logged-in users, click Add, and then click Save.

  4. Ensure the board's visibility is now All Users.

Important notes

There are two reasons why you might be unable to edit the filter or filter shares

  1. You need to be granted edit permission for this filter. Contact the filter's owner to be added to the Editors.

  2. If you are unable to edit the filter, you will need to contact its owner to be granted this permission.

  3. Ensure you have the Create Shared Object global permission. If not, contact your Jira administrator to grant it via the page ⚙ > System > Global Permissions.

Updated on September 25, 2025

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