Fix strike-through issues from Kanban Board in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

How to remove strike-through from issues in Jira Data Center Kanban Boards when they are moved from the Resolved status to any previous statuses?

Background

In the Kanban boards, a strike-through appears on issues if they are moved to a resolved state with the resolution set as part of the workflow transitions. Usually, you see those only in the column with issues in the DONE status category.

If these show up in other columns, it leads to confusion.

Environment

Jira Date Center Versions 8.x and higher

Diagnosis

  • Jira identifies the issue as resolved and will display the issue key with a strike-through.

  • This is identified by the Resolution field. If there is any value in this field, Jira assumes the issue is resolved. It is only unresolved when the field is empty (null in the database).

  • We need to clear out the value present in this field, and the only way to do that (without code) is to push the issue through a transition that has the standard clear resolution field post-function.

    These are usually placed on transitions that are reopen type, but not limited to.

Cause

Whenever an issue is moved to a completed/closed status by setting the Resolution as part of the workflow transition, it stores the value inside the database table jiraissue for the field Resolution.

When the issue is reopened or moved back to its previous state using a transition that doesn't use the Clear Resolution post function, the Resolution field will not be cleared. Therefore, Jira still assumes this issue is resolved, and a strike-through appears on the issue displayed as part of the board.

Solution

There are two options to solve this:

Using a workflow transition

  1. If you already have a standard transition with the Clear Resolution post function, you can use this transition.

  2. Otherwise, use the following steps:

    • Create or modify a transition to the appropriate status.

    • Add the post function Update the Field and set the Resolution field to None.

  3. Pass all affected issues through this transition.

Modifying the Resolution field in the database

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Take the database table (jiraissue) backup before making any changes to the database.

  2. Identify the issue ID from the database entries using the project key and issue number.

    SELECT CONCAT(jp.pkey, '-', ji.issuenum) AS issuekey, ji.id, ji.resolution FROM project jp JOIN jiraissue ji ON jp.id = ji.project WHERE CONCAT(jp.pkey, '-', ji.issuenum) = '<jira issue>';

    Replace <jira issue> with the issue key of the affected issue.

  3. Update the Resolution field for this issue and set it to NULL.

    UPDATE jiraissue SET resolution='NULL' WHERE id=<issueid>

    Replace <issueid> with the issue ID from the previous query.

  4. Once this is done, navigate to the issue and confirm that it reflects Unresolved in the Resolution field. Now, transition the issue to the next status to refresh the board cache and validate to confirm that the problem is resolved.

Updated on June 23, 2025

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