How to enable basic authentication when SAML fallback is not enabled

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After restoring a backup from another system, SAML may not be properly configured to log in. The administrator would like to log into the system, but the username and password fields are not available on the login page.

SAML fallback from Bypass SAML authentication for Jira Data Center is not enabled.

Environment

Jira Data Center with SSO enabled.

Diagnosis

On the Jira Login page, clicking on Login redirects the user to the IDP page instead of the user and password fields.

Cause

In Jira Administration → System →  Authentication methods, basic authentication has been disabled after enabling SAML.

Solution

  1.  Execute the following SQL to get the ID number for the login form:

    1 2 SELECT p.id, p.property_key ,ps.propertyvalue FROM propertystring ps JOIN propertyentry p ON ps.id = p.id WHERE p.property_key LIKE 'com.atlassian.plugins.authentication.sso.config.show-login-form';
  2. Run the following SQL to update the value to true

    1 UPDATE propertystring SET propertyvalue = 'true' WHERE id='<from_previous_SQL>';
  3. If you don't have a user with a password set in the internal directory, follow the steps from Restore Passwords to Recover Admin User Rights.

  4. Restart Jira 

Updated on March 12, 2025

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