Getting Notification from NoReply emails instead Username

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Notifications from Jira don't include the user who triggered the notification (Author of the action on the issue) in the "From" section of the email as it is viewed in the mail client.

Environment

All

Diagnosis

  1. We will want to confirm if the "From" header of the mail item includes the user who triggered the notification. To retrieve the header information (raw message data) please follow the steps outlined in Understanding Jira email headers. These steps will vary depending on the mail client being used.

  2. Once the raw message data has been extracted, you will want to look for the "From" header, which will represent what is being defined when the notification is sent from Jira.

    Example:

    1 2 3 4 5 6 7 8 9 10 11 From: "admin (Jira)" <jiratest@xxxx.com> To: johndoe@xxxx.com Message-ID: <JIRA.10203.1718767449000.1.1718767528470@Atlassian.JIRA> In-Reply-To: <JIRA.10203.1718767449000@Atlassian.JIRA> References: <JIRA.10203.1718767449000@Atlassian.JIRA> <JIRA.10203.1718767449268@f3647080e626> Subject: TEST-50 test 8 MIME-Version: 1.0 Content-Type: multipart/alternative; boundary="----=_Part_0_802507037.1718767511732" X-JIRA-FingerPrint: 43860afa3024ee16ab9af49f1eeeac39 Auto-Submitted: auto-generated Precedence: bulk

    1. You will notice in this example the "From" header is defined as "admin (Jira)" <jiratest@xxxx.com> and the expectation is that "admin (Jira)" would be rendered in the "From" address of the notification received.

  3. Check what is configured in the "Email from" setting of Jira Administration > System > General configuration. By default, this will be set to "${fullname} (Jira)" which will include the user who triggered the notification followed by "Jira"

    Example:

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Cause

It is not currently known what specific setting in the mail client defines what is rendered in the "From" address of emails received but from the header information above you can confirm that Jira is providing the correct content in the raw message data.

Solution

  1. Partner with your mail server admin to identify which specific setting (client side) is responsible for defining what is rendered in the "From" address of mail items received.

  2. If it is found that the "From" header in the raw message data does not include the actor triggering the notification AND the "Email from" setting has been adjusted from its default value you will want to revert this change by updating it to ${fullname} (Jira) and then save the changes.

    1. If this produces the same result please raise a request with Atlassian Support for additional assistance.

Updated on March 10, 2025

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