Get an internal server error message when trying to create a new issue through REST method

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

After trying to create a new issue through REST API, the following error appears in the terminal:

1 2 3 4 5 6 { "errorMessages": [ "Internal server error" ], "errors": {} }

Diagnosis

Start by making sure the json data are valid by referring the tutorial page.

You may also refer to atlassian-jira.log for a more complete error message or likely a java stack trace to help determine the root cause.

Additionally, you can enable HTTP access logs and HTTP dump logs on Logging and profiling page and run a test - this will create atlassian-jira-http-access.log and atlassian-jira-http-dump.log files. Note that this will produce a lot of logging and we advise against leaving it enabled.

Cause

The problem is the JSON data are not completely correct or Jira is unable to generate a valid response for the request.

Solution

Resolution

Refer to the JIRA REST API official documentation for more examples.

Updated on April 2, 2025

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