Fix JQL error "The option 'xxxx' for field 'xxxx' does not exist" with Jira DC cascading select fields

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

While searching for issues that match the selected values of a "cascading select" custom field via JQL, an error occurs: "The option 'XXX' for field 'XXXX' does not exist."

Example error message "the option 'Country1' for field 'Cascading Field'does not exist." with JQL "Cascading Field" in ("Country1")

Environment

Jira Data Center version 9.x or later

Diagnosis

Navigate to Administration > Issues > Custom fields and search for the field name. You should find more than one field.

Cause

This error occurs when there are multiple custom fields with the same name (non-case sensitive).

Example result in custom fields when searching for fields, there is Cacscading Field (both first letters upper-case) and cascading field (all lower-case)

Solution

To resolve this issue:

  • You can use the custom field ID while searching for issues that match the selected values of a "cascading select" custom field in the JQL. Please follow Get custom field IDs for Jira and Jira Service Management to find the custom field's ID. Example JQL: cf[10306] in ("Country1")

  • Or rename the duplicate cascading select custom field to a unique name.

Updated on June 30, 2025

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