Fix Jira Dashboard Access Error: Property Column Not Found After Upgrade
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
User(s) unable to access JIRA Dashboard
The following appears in the atlassian-jira.log:
Mar 12, 2013 11:04:14 AM com.sun.jersey.server.impl.application.WebApplicationImpl onException
SEVERE: Internal server error
com.opensymphony.module.propertyset.PropertyImplementationException: Property 'column4' not found
at com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.getType(OFBizPropertySet.java:162)
at com.opensymphony.module.propertyset.ofbiz.OFBizPropertySet.remove(OFBizPropertySet.java:203)
at com.atlassian.core.ofbiz.util.OFBizPropertyUtils.removePropertySet(OFBizPropertyUtils.java:34)
at com.atlassian.jira.portal.OfbizPortletConfigurationStore.delete(OfbizPortletConfigurationStore.java:112)
at com.atlassian.jira.portal.CachingPortletConfigurationStore.delete(CachingPortletConfigurationStore.java:194)Solution
Cause
This is usually caused by a legacy Dashboard Gadget or Portlet which is corrupt after an upgrade.
Resolution
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
This fix involves running SQL statements on JIRA's database.
Run the following query to identify any Dashboards that the user 'test' has
select * from portalpage where username='test';ℹ️ Replace the 'test' username in the above SQL with the affected users's username.
The query will return results similar to these:
ID | USERNAME | PAGENAME | DESCRIPTION | SEQUENCE | FAV_COUNT | PPVERSION | LAYOUT |
12269 | test | My first Dashboard |
|
| 4 | 76 | AA |
11573 | test | My test Dashboard |
|
| 5 | ||
12242 | test | Another test dashboard |
|
| 5 |
Next, determine the Dashboard that needs to be removed by name in the PAGENAME column. Run the following query to remove a specific Dashboard:
DELETE FROM "portalpage" WHERE "PAGENAME"='<Dashboard_name_value>';ℹ️ Make sure to replace the <Dashboard_name_value> with the actual name of the Dashboard you wish to delete.
Alternatively, remove all Dashboards that a user has with the following query:
DELETE FROM "portalpage" WHERE "USERNAME"='<user_name>';ℹ️ Make sure to replace the <user_name> with the actual name of the user you wish to delete.
Was this helpful?