Error "Could not fetch Assets objects" in Assets object custom field

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

When trying to search for Asset objects in an Asset objects custom field, one of the below errors is returned.

The Jira Server was contacted but has returned an error response. We are unsure of the result of this operation.

Could not fetch Assets objects. Please refresh the page and try again

Cause

Some attributes mentioned in the sections 'Allow search filtering by these attributes' and/or 'Object attributes to display on issue view' of the Asset object custom field configuration may be unavailable in the attribute list of that Assets object type. Additionally, recent platform updates introduced stricter AQL handling. For example, the use of 'objectTypeId' in AQLs has been replaced by 'objectType'. Update your AQL queries accordingly (e.g., change 'objectTypeId = 137' to 'objectType = "Your Object Type Name"') to resolve such issues. Note that 'objectTypeId' may still work in API calls without a selected schema.

Solution

  1. Go to your cloud site.

  2. Click on Settings(cog wheel) > Issues > Custom fields

  3. Search for the Asset object custom field and right click on the 3 dots(...) beside it

  4. Click on Contexts and default value and then Edit Assets object/s field configuration

  5. Open the cloud site in another tab or just duplicate the already open tab.

  6. Click on the Assets option from the top menu bar and then View all object schemas Note: If a schema fails to load with an error message ('There's been a problem loading the object schemas. Try refreshing the page'), ensure the user account has the appropriate Jira Service Management license assigned for the relevant environment (e.g., sandbox or production).

  7. Click on the object schema which has the object type

  8. Select the object type and go to its Attributes tab

  9. Compare the attributes from step 4 and step 9.

  10. In the Edit Asset object/s field configuration section of the Asset object custom field, remove the attributes which are not present in the Attributes tab of the object type. To configure attributes for display during asset search or creation, navigate to the 'Allow search filtering by these attributes' section and add the required attributes there. Additionally, if schema references or dependencies are broken after updates or migrations, consider performing a sandbox copy to refresh the environment, as this might help resolve lingering

  11. Once done, click Save to save the changes.

Updated on February 24, 2026

Still need help?

The Atlassian Community is here for you.