Enabling Content Delivery Network (CDN) breaks the loading and rendering of JIRA pages

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

After enabling the CDN, below are some generic issues that could be faced while accessing different Jira pages

  • Some images or icons may not load properly due to caching issues.

  • The page layout may appear broken due to CSS files not being loaded correctly.

  • JavaScript errors may occur causing certain features of the page to malfunction.

Environment

All Jira versions

Diagnosis

Ensure that your content delivery network (CDN) is properly configured and functioning correctly in SAFE mode.

Cause

One of the custom plugins may interrupt and break the rendering of pages. In some cases, the Data Protection and Security Toolkit for Jira (DLP) plugin was found to be causing issues.

Solution

  • Enter Jira in SAFE Mode and test. If the issue is fixed and no longer reproducible in SAFE mode, then enable each plugin one by one and test the issues until you identify the offending plugin.

  • Once you have identified the plugin causing the issue, disable it and report it to the plugin vendor to see if there is any workaround or fix available.

Updated on March 20, 2025

Still need help?

The Atlassian Community is here for you.