Emoji fail to display in work item view on Jira Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.
Summary
Emojis display correctly for some work items, but fail to display on others. This primarily occurs in fields like Description, though may occur in others.
Let's imagine our Jira site has two work items: TEST-101 and TEST-202. Emoji have been added to the Description of both work items, but only displays properly in TEST-101.
Diagnosis
Check text type with the Jira REST API
Anything that is typed in the issue description is converted to Atlassian Document Format (ADF). We can use the Get Issue Rest API to check ADF representation for work items and compare the results. For example:
TEST-101 ADF Description field from Get Issue API call
...
"description" : {
"content" : [
{
"content" : [
{
"attrs" : {
"id" : "ae2eb476-ed83-4fd7-98f6-e48053ea0f06",
"shortName" : ":my_custom_emoji:",
"text" : ":my_custom_emoji:"
},
"type" : "emoji"
},
{
"text" : " > My custom emoji",
"type" : "text"
}
],
"type" : "paragraph"
}
],
"type" : "doc",
"version" : 1
},
...
TEST-202 ADF Description field from Get Issue API call
"description" : {
"content" : [
{
"content" : [
{
"text" : ":my_custom_emoji: > My custom emoji",
"type" : "text"
}
],
"type" : "paragraph"
}
],
"type" : "doc",
"version" : 1
},
If we compare these examples, we see a difference in the content types used. TEST-202 (our failstate work item) uses the text type only, while TEST-101 uses the emoji type.
Cause
Improper text tags
There are three kinds of emoji tags available in ADF. TEST-202 was created programmatically using a third-party app, which did not add the proper ADF representation for emojis. There may also be additional causes to explain the behavior, as seen in the Solution section.
Solution
Fix work items created by third-party apps
There's no real way to correct this problem unless the app's text tagging logic is fixed. App developers must fix the third-party application code to add proper emoji tags to the issue description when calling Create Issue API programmatically.
Fix work items created directly in Jira
For emoji problems on work built using Jira's UI, API, or automation:
If the problem exists with a site emoji, check that the emoji is uploaded to the site
If it is a standard or Atlassian emoji, use the ADF builder or ADF viewer to confirm that emoji tags are correct
If emoji names (:my_custom_emoji:) are copied from a text editor and pasted straight into the work item, they won't be converted to emojis due to JRACLOUD-80553
If you copy a work item description that contains an emoji from work item A to work item B without pasting it in any intermediate text editor, it will show the emojis accordingly
For all tags with emoji type, the image file is downloaded from a Content Delivery Network (CDN). Check on a HAR file (Network tab within browser Developer Tools) if there are any issues with the CDN requests to load the emoji file.
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