Emailed requests are not created with an error in the logs indicating that a custom field is not correctly filled in

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

Fix the following error in your service project's email channel logs: Your request could not be created. Please check the fields have been correctly filled in. <Custom field name>

Diagnosis

You see the error message in the project's email channel logs in Project settings > Email > View logs

Cause

Workflow validators have a field requirement

This error happens when the workflow used by that request type has a Validator in the Create transition, which requires a value for that custom field.

Solution

Adapt the workflow or request type used by the email channel

To correct this issue, please do one of the following:

  • Remove the Validator from the Create transition for the workflow used by that request type

  • Modify the request type used for the mail handler to specify a default value for the custom field

More information on how to perform these actions can be found at:

Updated on September 25, 2025

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